Enlighter – Customizable Syntax Highlighter代码高亮插件

描述

Enlighter是WordPress的免费,易于使用的语法高亮工具。高亮显示由EnlighterJS javascript库提供,以提供美观的代码外观。

使用它就像添加一个新的Enlighter源代码块(Gutenberg)一样简单,然后插入要突出显示的代码:Enlighter会处理其余的工作!

包含一个易于使用的Theme-Customizer,可以修改内置主题,而无需任何CSS知识!
它还支持自动创建选项卡窗格以一起显示代码组(适用于多语言示例,例如html + css + js)


插件功能
  • 古登堡编辑器完全集成
  • 完全经典编辑器集成(TinyMCE)
  • 支持所有常用语言
  • 强大的通用高亮引擎,适用于未知语言
  • 主题定制器,包括LIVE预览模式
  • 内联语法突出显示
  • bbPress简码+降价代码块支持
  • 选项页面中提供了高级配置选项(CDN使用情况,..)。
  • 支持代码组(在选项卡窗格中显示多个代码块)
  • 可扩展的语言和主题引擎–添加您自己的引擎。
  • 基于简单CSS的主题
  • 集成CSS文件缓存(适用于高流量站点)
  • Webfont Loader将缺少的Monospace字体添加到您的网站
  • 完全符合GPDR –无需外部资源,也不会聚合任何数据

古腾堡编辑器集成
  • 通过“ Enlighter源代码”模块进行完全编辑器集成
  • 经典编辑器帖子的自动转换(将代码块转换为Enlighter Sourcecode块)
  • 将旧版代码块转换为Enlighter Gutenberg块(手动转换)
  • 文件与用法
  • 编辑器插件存储库

经典编辑器(TINYMCE)集成

降价
  • Markdown围栏代码块
  • 通过反引号(包括特定于语言的插件)的内联语法突出显示
  • 文件与用法

TEXTEDITOR / SHORTCODES(旧版)
不推荐使用简码,只应在文本编辑器模式下使用 -切勿在Gutenberg Editor或Classic Editor中使用它们!

  • 通过使用简码和快速标记,易于使用的文本编辑器模式
  • 内容,注释和小部件中的简码
  • 独立的Shortcode-Processor可以避免Text-Editor模式下的wpautop过滤器问题

支持的语言(内置)
如果您的语言不可用,请尝试涵盖许多编程语言的通用模式 -或在GitHub上请求新的语言

隐藏内容,您需要满足以下条件方可查看

人已赞赏
2 条回复 A文章作者 M管理员
  1. 感谢大佬分享这么好的插件

  2. 测试评论

个人中心
今日签到
有新消息 消息中心
有新私信 私信列表
搜索